idea打war包时,JDK版本的问题解决方式

 muxiongxiong   2021-08-19 06:00   375 人阅读  0 条评论

大家好,我是雄雄,欢迎关注微信公众号:????雄雄的小课堂????。

????‍????前言

今天,记录个到现在为止还没搞清的问题,这个问题浪费了我几个小时的时间,基本上昨天晚上啥也没干,都在弄这个了,主要是还没弄出来;在各个技术群里面也都问了,有的说是项目的jar问题,有的伙伴说是Tomcat的问题,还有的说是jdk的问题,按照这些问题我都一一多了 拍爱排查 ,做了如下的几件事情:

  • ????服务器重启了N遍

  • ????项目打包打了N遍

  • ????Tomcat安装了N遍

  • ????JDK安装了N遍

  • ????Nginx配置了N遍

  • ????……

一直在做这些重复的工作,最后还是没有解决掉。

????‍????项目说明

项目是一个门户网站,使用的技术有点儿稍稍老,用的**publiccms**,不过也还好,不管技术多老,没有涉及到编码,赖不上。只是最近一直在开发springboot项目,所以一看到需要用Tomcat的,就稍微有点儿抵触。

这不,publiccms相关技术网上的资料比较少,终于边看文档遍自己琢磨,将整个站完成,到了最后部署上线阶段,问题就在这一块儿出的。

????‍♀️问题说明【重点】

idea中打war包,编译启动,0错误,可以正常运行,但是将idea中打包好的war包放在tomcat下面,发现一起动就报错,本地这样,云服务器上也是一样的。

image-20210818141741154

访问页面的时候,直接就是404

image-20210818141825050

能出现这样,服务器肯定是没有问题的,一定是项目的问题,于是将自己打好的war包文件发给开发的朋友,看看在他的的tomcat中可以启动不,得到的反馈是:可以。

image-20210818142149570

可以确定的是项目打包确实存在问题,tomcat本身能有什么问题,今天就把重点放在了ideawar的问题上,重新配置tomcat,结果发现有个JRE的选择,上面默认是1.8(分析起来也没啥问题),尝试着换成自己指定磁盘下面的jre,然后接着打包。

image-20210818143745164

打包完成后,将war文件放在tomcatwebapp下面,启动,发现错误消失。

但是神奇的是,当我把JRE继续改成原来默认的1.8,重新打包,问题还是没有出现,至今没有搞明白,有小伙伴知道这是咋回事的吗?

????‍♂️最后点个赞和在看在走呗~

本文地址:http://www.xn--ypzn79ca.com/?id=1299
版权声明:本文为原创文章,版权归 muxiongxiong 所有,欢迎分享本文,转载请保留出处!

 发表评论


表情

还没有留言,还不快点抢沙发?